29
2012
08

ubuntu 安装deb的qq的时候报错 version number does not start with digit

ubuntu 11.04默认没安装linux qq。不想使用web的。所以在腾讯下载 一个linux版本的qq安装

root@ubuntu:/home/chlyyangwei/下载# dpkg -i linuxqq_v1.0.2-beta1_i386.deb
dpkg:处理 linuxqq_v1.0.2-beta1_i386.deb (--install)时出错:
parsing file '/var/lib/dpkg/tmp.ci/control' near line 7 package 'linuxqq':
版本字符串 v1.0.2-beta1 中有错误: version number does not start with digit
在处理时有错误发生:
linuxqq_v1.0.2-beta1_i386.deb


root@ubuntu:/home/chlyyangwei/下载# dpkg-deb -x linuxqq_v1.0.2-beta1_i386.deb linuxqq

root@ubuntu:/home/chlyyangwei/下载# dpkg-deb -e linuxqq_v1.0.2-beta1_i386.deb linuxqq/DEBIAN

root@ubuntu:/home/chlyyangwei/下载# vi linuxqq/DEBIAN/control
Package: linuxqq
Priority: extra
Section: Internet
Installed-Size: 6264
Maintainer: Tencent Inc.
Architecture: i386
Version:1234  修改的是这里。原本是v1.2-beta1
Depends: gtk2.0-binver-2.10.0, libc6, libcairo2, libglib2.0-0, libgtk2.0-0, libpango1.0-0
Description: QQ - The most popular free instant messaging program in China.
* Chat with more than 590,000,000 people all over the world.
* Free to download or distribute absolutely.

root@ubuntu:/home/chlyyangwei/下载# dpkg-deb -b linuxqq linuxqq.deb
dpkg-deb:正在新建软件包 linuxqq,包文件 为 linuxqq.deb。

root@ubuntu:/home/chlyyangwei/下载# dpkg -i linuxqq.deb

« 上一篇 下一篇 »

发表评论:

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。